MySQL question

    • MySQL question

      First hello to everyone.

      Second, I'm very knew to all of the sever/host related stuff even though I've had managed VPS accounts for quite some time now, please try to answer my question as if you're explaining things to a 5 year-old child (I hope I'm not that bad).

      My questions are related to this error I'm receiving on a WoltLab Burning Board forum that I own. If I go to Maintenance > Rebuild Users in my ACP I see this:

      The MySQL configuration option “innodb_flush_log_at_trx_commit” is set to “1”, slowing down certain database queries. It is highly recommended to set its value to “2”

      I tried editing the /etc/my.cnf file as Alexander Ebert suggested here when I asked the question, you can see my results there. I'm a little confused now after reading "GTB's" reply. I followed this tutorial to edit the file, was anything supposed to be stopped while I made the change or was I just supposed to make the change, save what I did and then restart MySQL?


      I have already sent a support ticket to my host but would really like to learn how to do these things on my own and any help is really appreciated.
    • Paul wrote:

      was anything supposed to be stopped while I made the change or was I just supposed to make the change, save what I did and then restart MySQL?

      What OS are you using? If you are using CentOS, are you by chance using CentMin Mod? In CentOS (and a few other distro's) the my.cnf is in the /etc location - but others (like Debian) put it in /etc/mysql.
      Setting that parameter to a 2 setting can result in some data loss... normally up to about a seconds worth from my understanding.
      If the correct my.cnf was edited, simply restarting mysql should make it take effect.
      Also, are you using Percona, Oracle's mySQL or MariaDB?

      EDIT:
      OK, on further reading.. are you trying to edit that file as your normal user account on the VPS? If so, odds are that's not going to work.
      You will have to either assume root priv's via sudo or sign in via root (NOT recommended - in fact, you should not be able to SSH in as root at all).
    • Tracy wrote:

      OK, on further reading.. are you trying to edit that file as your normal user account on the VPS? If so, odds are that's not going to work.
      You will have to either assume root priv's via sudo or sign in via root (NOT recommended - in fact, you should not be able to SSH in as root at all).
      I was logged in as a normal user. After creating a support ticket I was told that I could have done it globally while being logged in as root... so yes I can do things with SSH as root. How do I give permissions to a user (myself) that allows them to do things that the root user can do? Or is that even possible?
    • Paul wrote:

      I give permissions to a user (myself) that allows them to do things that the root user can do? Or is that even possible?
      As a normal user, type sudo and see what it shows. If it tells you command not found (or something similar) then you need to install sudo and configure it to allow your normal user to use it (it allows your user to be granted root priv's when running a command/program). If this is a managed system, then tell your host you want sudo installed and your normal user account granted sudo privs for root access.
      What OS are you using?
      Also, for security, you should really disable root logons via SSH. If using a VPS, I'm sure they have a KVM type client that allows you log on from your VPS control panel - most of them do.