USN-3887-1: snapd vulnerability

  • USN-3887-1: snapd vulnerability


    Ubuntu Security Notices wrote:

    snapd vulnerability

    A security issue affects these releases of Ubuntu and its derivatives:

    • Ubuntu 18.10
    • Ubuntu 18.04 LTS
    • Ubuntu 16.04 LTS
    • Ubuntu 14.04 LTS


    snapd could be made to run programs as an administrator.

    Software Description

    • snapd - Daemon and tooling that enable snap packages


    Chris Moberly discovered that snapd versions 2.28 through 2.37 incorrectly validated and parsed the remote socket address when performing access controls on its UNIX socket. A local attacker could use this to access privileged socket APIs and obtain administrator privileges. On Ubuntu systems with snaps installed, snapd typically will have already automatically refreshed itself to snapd 2.37.1 which is unaffected.

    Update instructions

    The problem can be corrected by updating your system to the following package versions:

    Ubuntu 18.10
    snapd - 2.35.5+18.10.1
    Ubuntu 18.04 LTS
    snapd - 2.34.2+18.04.1
    Ubuntu 16.04 LTS
    snapd - 2.34.2ubuntu0.1
    Ubuntu 14.04 LTS
    snapd - 2.34.2~14.04.1

    To update your system, please follow these instructions:

    In general, a standard system update will make all the necessary changes.